We are aware of some ongoing issues with the new audio engine. This is due to an incorrect detection of certain devices as 7.1 surround sound, even if they are set as stereo. We are currently working on resolving issue and hope to have an update soon.

In the meantime, you may try the following steps to self-diagnose this issue. The steps you follow may depend on the device(s) you are using.

  • Realtek Devices

  • SteelSeries Arctis 5 (and possibly other versions)


Realtek Devices

  • In the bottom right corner of your screen, right click the sound icon and click “Open Sound settings”.

  • On the right hand side of that opened window, click on “Sound Control Panel” under “Related Settings”.

  • Click on the "Recording" tab.

  • Right click the "Stereo Mix" device and then click on "Enable".

  • Once enabled, launch Gamecaster, click on the + icon alongside “Audio Mixer” and find the “Stereo Mix” device. It may be listed under the Microphone category.

  • Start a Recording, play some music, and confirm you are now receiving audio.


SteelSeries Arctis Headsets

  • In the bottom right corner of your screen, right click the sound icon and click “Open Sound settings”.

  • Click on the "Choose your output device" dropdown and ensure your output device is set to the "Game" device. If you are using the "Chat" device, your game audio and other sounds will route through this, resulting in no sound on Gamecaster. We recommend this setting regardless to get the most out of your headset.

  • Once selected, launch Gamecaster, confirm you have "Default Speakers" added to the mixer, and then start a Recording, play some music, and confirm you are now receiving audio.

Did this answer your question?